Créer des étiquettes avec les adresses d’un tableau Calc

Il faudra au préalable avoir déjà créé le tableau contenant les adresses avec Calc.

Il y a trois étapes différentes pour réaliser des étiquettes à partir d’un classeur OpenOffice. Et il y a deux façons de faire pour la première étape (ces deux façons de faire sont expliquées dans ce document).

Créer des étiquettes

1ere façon de faire

Ouvrez OpenOffice.

Ensuite, allez dans le menu « Fichier », puis dans « Nouveau », et cliquez sur « Etiquettes » :

clip_image002

Choisissez la marque de vos étiquettes (voir cadre rouge de l’image ci-dessous) et choisissez le type de vos étiquettes (voir cadre vert) :

clip_image004

Allez ensuite dans l’onglet « Options », et cochez la case « Synchroniser le contenu ». Cliquez ensuite sur le bouton « Nouveau document » :

clip_image006

Ensuite, allez dans le menu « Insertion », puis dans « Champs », puis cliquez sur « Autres » :

clip_image008

Allez dans l’onglet « Base de données » et cliquez sur le bouton « Parcourir » :

clip_image010

Cherchez votre fichier tableur contenant vos adresses.

Ensuite, cliquez sur le petit + qui apparait juste devant le nom de votre base de données (en fait, le nom qui sera ajouté est le nom de votre fichier), puis cliquez sur le petit plus devant le nom de la feuille de votre tableur :

clip_image012

Pour rappel, le nom qui apparaitra dans la fenêtre ci-dessus correspond au nom qui est dans le tableur en bas de l’écran :

clip_image014

Vous pouvez cliquer dans l’étiquette pour en modifier facilement le contenu. Ainsi, vous pouvez ajouter des espaces ou aller à la ligne entre chaque champ inséré. Pour insérer un champ, il suffit de double cliquer dessus dans la fenêtre ressemblant à cette image (voir cadre orange) :

clip_image016

Ce qui donne à peu près ceci (la civilité correspond à « M. » ou « Mme », …) :

clip_image018

Il reste une dernière chose avant de cliquer sur le bouton « Fermer ». Cliquez après le dernier champ inséré (donc par rapport à l’image ci-dessus, après « <Ville> »), et cliquez sur « Enregistrement suivant ».

Ensuite, cliquez sur le petit + devant la base de données qui correspond à votre tableur (voir cadre rouge), et cliquez sur la feuille de votre tableur :

clip_image020

Cliquez ensuite sur « Insérer », et cliquez sur « Fermer ».

Après avoir cliqué sur « Insérer », vous vous direz surement qu’il ne s’est rien passé, car visuellement on ne voit rien changer. Vous auriez presque raison si vous ne connaissiez pas la raison pour laquelle je vous ai demandé de faire ça :

En fait, après, on va sélectionner quelles lignes on veut avoir comme étiquettes. Sans cette opération, le fait de synchroniser les étiquettes aurait mis la même personne sur toutes les étiquettes.

Du coup, si vous essayez de supprimer en utilisant la touche clip_image022de votre clavier, visuellement, rien ne sera supprimé (enfin sauf si vous maintenez la touche enfoncée auquel cas tout se supprimera). Par contre, si vous appuyez une deuxième fois, le champ « <Ville> » sera supprimé.

Maintenant, nos étiquettes sont prêtes. Il ne reste plus qu’à cliquer sur « Synchroniser les étiquettes » :

clip_image024

Nos étiquettes sont prêtes, mais il faut personnaliser un peu nos étiquettes. Par la mise en forme par défaut est pas très jolie. Pour ceci, passez à l’étape 2 page 11.

2eme façon de faire

Pour cette autre façon de faire, il nous faut une base de données contenant les informations nécessaires. Pas de panique, on ne va pas créer une nouvelle base de données en commençant de 0, on va créer une base de données à partir de votre fichier fait avec le tableur de OpenOffice.

Pour ceci, ouvrez OpenOffice et cliquez sur « Fichier », puis allez dans « Nouveau », et cliquez sur « Base de données » :

clip_image026

Cochez ensuite la case « Se connecter à une base de données existante » (voir cadre orange de l’image ci-dessous). Ouvrez la zone déroulante (voir cadre rouge) et cliquez sur « Classeur ». Cliquez ensuite sur le bouton « Suivant » :

clip_image028

Cliquez sur le bouton « Parcourir » et cherchez votre fichier contenant vos adresses. Cliquez ensuite sur le bouton « Suivant » :

clip_image030

Décochez la case « Ouvrir la base de données pour édition » et cliquez sur « Terminer » :

clip_image032

Ensuite, il vous sera demandé d’enregistrer le fichier de base de données. Mettez le par exemple au même endroit que le tableau fait avec Calc qui contient vos adresses. Vous pouvez par exemple le nommer « Base de données adresses », ou pour ceux qui n’auraient pas envie d’un nom aussi long, « BDD adresses ».

 

Ouvrez OpenOffice.

Ensuite, allez dans le menu « Fichier », puis dans « Nouveau », et cliquez sur « Étiquettes » :

clip_image033

Choisissez la marque et le type de vos étiquettes (voir cadre rouge), et choisissez la base de données ayant le nom que vous avez donné précédemment (voir cadre bleu) :

clip_image035

Dans la liste déroulante suivante, sélectionnez le nom de la feuille du tableur qui contient les adresses :

clip_image037

Si quelque chose apparait dans la zone de texte à gauche (voir cadre orange de l’image ci-dessus), supprimez le.

Ensuite, dans la liste déroulante suivante, cliquez sur « Civilité » (ou si vous n’avez pas la civilité dans votre tableau, passez à la ligne suivante), cliquez sur la flèche (voir cadre bleu de l’image ci-dessous) et appuyez sur la barre « Espace » de votre clavier :

clip_image039

Ensuite, dans la même zone déroulante, cliquez sur « Nom », cliquez sur la flèche et appuyez sur la barre « Espace » de votre clavier.

Ensuite, dans la même zone déroulante, cliquez sur « Prénom », cliquez sur la flèche et appuyez sur la touche « Entrée » de votre clavier.

Ensuite, dans la même zone déroulante, cliquez sur « Adresse », cliquez sur la flèche et appuyez sur la barre « Entrée » de votre clavier.

Puis, dans la même zone déroulante, cliquez sur « Code postal », cliquez sur la flèche et appuyez sur la barre « Espace » de votre clavier.

Pour terminer, toujours dans la même zone déroulante, cliquez sur « Ville », cliquez sur la flèche et appuyez sur la barre « Entrée » de votre clavier.

Cliquez ensuite sur l’onglet « Options », et si elle n’est pas déjà cochée, cochez la case « Synchroniser le contenu ». Cliquez sur « Nouveau document » :

clip_image040

Vos nouvelles étiquettes sont presque prêtes. Il va falloir les personnaliser et ensuite les remplir.

Personnalisation des étiquettes

Pour la personnalisation, il suffit d’utiliser les fonctions habituelles comme dans le traitement de texte. Quelques petites choses à savoir tout de même :

• Pour appliquer la même mise en forme partout, cliquez sur ce bouton :

clip_image024[1]

• La taille des étiquettes n’est pas limitée à la petite barre horizontale qui est juste en dessous de la dernière ligne de texte de la première étiquette (voir ellipse orange de l’image ci-dessous).

clip_image042

Rien ne vous empêche d’appuyer sur la touche « Entrée » de votre clavier (après « <Ville » par rapport à l’image ci-dessus) pour agrandir la zone utilisée sur l’étiquette :

clip_image044

3) Remplissage des champs

Maintenant, il va falloir remplir les champs des différentes étiquettes.

Vérifiez bien que les étiquettes ont toutes la même mise en forme. Pour ceci, cliquez sur le bouton « Synchroniser les étiquettes » :

clip_image024[2]

Pour ceci, allez dans le menu « Affichage », et cliquez sur « Sources de données » :

clip_image046

Si le contenu de votre carnet d’adresses ne s’affiche pas, cliquez sur les petits + devant votre fichier de carnet d’adresses et devant « Tables ». Cliquez ensuite sur le nom de votre feuille dans le tableur :

clip_image048

Le contenu de votre carnet d’adresses devrait s’afficher sur la droite.

Ensuite, sélectionnez les différentes lignes que vous voulez voir apparaitre dans les étiquettes. Pour ceci, n’hésitez pas à utiliser la touche clip_image050ou la touche clip_image052(comme pour la gestion des fichiers) et cliquez sur les en-têtes de lignes pour les sélectionner (voir cadre violet de l’image ci-dessus).

Si vous souhaitez sélectionner plusieurs lignes qui se suivent, cliquez sur la première ligne (enfin sur l’en-tête de la première ligne) de la liste qui vous intéresse, descendez l’ascenseur, et tout en maintenant la touche clip_image052[1]enfoncée, cliquez sur l’en-tête de la dernière ligne qui vous intéresse.

De la même façon, si vous souhaitez sélectionner des lignes qui ne se suivent pas, appuyez sur la touche clip_image050[1] tout en cliquant en même temps sur les en-têtes de lignes.

Cliquez ensuite sur « Données dans les champs » :

clip_image054

Et voilà de jolies étiquettes ! (enfin après, il vous reste toutes les mises en forme à faire)

Derniers détails

Cas possibles de non fonctionnement de ces quelques pages :

• Vous avez une ancienne version de OpenOffice

• Vous n’avez pas encore enregistré votre document d’étiquettes

• Vous avez inséré une ligne blanche en tout début de votre tableur (ce qui ne permet pas l’affichage des noms des colonnes lors de l’insertion de champs et provoquera l’apparition d’une première étiquette avec les noms des champs)

Si vous modifiez la mise en forme après avoir mis le contenu dans les champs des étiquettes, il faudra que vous cliquiez sur le bouton « Synchroniser le contenu » pour mettre la même mise en forme partout, amis aussi que vous recliquiez sur « Données dans les champs » afin de remettre les bonnes personnes dans les étiquettes.

2 commentaires


  1. Bonsoir,

    Je n'arrive pas à faire plusieurs planches de 3×6 enregistrements, dans le but de les imprimer par la suite, avec LibreOffice 4.2

    Faut-il faire ces planches de suite après avoir fait le classeur  "Calc" et avant de créer la base?

    Merci beaucoup

    A.O

    Répondre

    1. Bonjour

      En fait "Calc" contient les données, et la base ne fait que pointer vers le fichier Calc.

      Du coup, il faut créer son tableau d'abord dans Calc, et faire les planches ensuite avec le module d'étiquettes (de préférence en indiquant le format de papier s'il y en a un, sinon c'est très lourd à faire manuellement). La procédure permet de créer la base à partir du fichier Calc (fichier de base qui ne fait que pointer vers le tableur).

      En espérant avoir été plus clair.

      Loïc

      Répondre

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *